We are continuing to monitor for any further issues.
Posted Jun 05, 2026 - 15:21 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 05, 2026 - 15:20 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 05, 2026 - 15:16 CEST
Investigating
We are currently experiencing degraded performance affecting a subset of users. Some requests may take longer than expected to complete, and certain operations may be intermittently delayed.
The engineering team is actively investigating the issue and working to identify the root cause. Mitigation efforts are in progress.
Posted Jun 05, 2026 - 15:10 CEST
This incident affected: CheckHub API, Candidate FileBox, CheckHub Admin, and CheckHub Admin Next.